What Operating System does Plesk 7 require?

On this page you will find the answers to questions that are frequently asked.

Plesk requirements

Plesk 7 runs on Red Hat 7.3, Red Hat 9.0, Red Hat Enterprise Linux 2.1 (AS/ES), Red Hat Enterprise Linux 3.0 (AS/ES), FreeBSD 4.9, Mandrake 9.2, Suse 9.0 and Fedora.


Category: Algemeen



Related questions



All questions Previous page



* All prices on our website exclude VAT - Terms and conditions - Acceptable Use Policy -

  • Hosting Concepts
  • Powered by Parallels
  • iDeal
  • Dell servers
  • RBS Worldpay
  • Openprovider

All rights reserved to Flexservers dedicated server hosting.

Plesk requirements